Bouncy Castle JCE Provider 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1185708 漏洞类型
发布时间 2018-06-04 更新时间 2018-06-10
CVE编号 CVE-2016-1000345 CNNVD-ID CNNVD-201806-158
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201806-158
|漏洞详情
Bouncy Castle JCE Provider是一款基于Java的加密包。 Bouncy Castle JCE Provider 1.55及之前版本中的DHIES/ECIES CBC模式存在安全漏洞。攻击者可通过填充利用该漏洞确定造成解密失败的情况。
|参考资料
resource:
hyperlink:https://github.com/bcgit/bc-java/commit/21dcb3d9744c83dcf2ff8fcee06dbca7bfa4ef35#diff-4439ce586bf9a13bfec05c0d113b8098