marked 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1186131 漏洞类型 跨站脚本
发布时间 2018-06-01 更新时间 2019-10-17
CVE编号 CVE-2016-10531 CNNVD-ID CNNVD-201805-1204
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201805-1204
|漏洞详情
marked是美国Christopher Jeffrey软件开发者的一款使用JavaScript编写的Markdown解析器和编译器。 marked 0.3.5及之前版本中存在跨站脚本漏洞,该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。
|参考资料
resource:
hyperlink:https://github.com/chjj/marked/pull/592
resource:
hyperlink:https://github.com/chjj/marked/pull/592/commits/2cff85979be8e7a026a9aca35542c470cf5da523
resource:
hyperlink:https://nodesecurity.io/advisories/101