electron-packager 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1186141 漏洞类型
发布时间 2018-06-01 更新时间 2018-06-01
CVE编号 CVE-2016-10534 CNNVD-ID CNNVD-201805-1201
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201805-1201
|漏洞详情
electron-packager是一款用于将应用程序打包成基于不同平台的可执行文件的工具。 electron-packager 5.2.1版本至6.0.0版本和6.0.0版本至6.0.2版本中存在安全漏洞,该漏洞源于‘--strict-ssl’命令行选项被默认设置为‘false’。攻击者可利用该漏洞实施中间人攻击,并将有效的下载替换成恶意下载。
|参考资料
resource:
hyperlink:https://github.com/electron-userland/electron-packager/issues/333
resource:
hyperlink:https://nodesecurity.io/advisories/104