openSUSE libxcrypt不安全口令哈希漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1186198 漏洞类型 加密问题
发布时间 2008-07-22 更新时间 2008-09-11
CVE编号 CVE-2008-3188 CNNVD-ID CNNVD-200807-356
漏洞平台 N/A CVSS评分 6.2
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200807-356
|漏洞详情
NovellopenSUSE是美国Novell公司的一套基于Linux的自由操作系统。openSUSE使用libxcrypt库计算口令的哈希值,可以配置为使用DES、MD5或blowfish。由于libxcrypt库中的一个漏洞,即使/etc/default/passwd文件中已经配置了MD5,系统仍会忽略这个设置使用DES算法。相对较弱的算法可能有助于攻击者的暴力破解。
|参考资料

来源:SUSE
名称:SUSE-SA:2008:036
链接:http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00008.html
来源:XF
名称:opensuse-libxcrypt-weak-security(43927)
链接:http://xforce.iss.net/xforce/xfdb/43927
来源:BID
名称:30301
链接:http://www.securityfocus.com/bid/30301
来源:SECUNIA
名称:31339
链接:http://secunia.com/advisories/31339
来源:SECUNIA
名称:31096
链接:http://secunia.com/advisories/31096
来源:SUSE
名称:SUSE-SR:2008:016
链接:http://lists.opensuse.org/opensuse-security-announce/2008-08/msg00001.html