Kaspersky kl1.sys驱动本地栈溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1186628 漏洞类型 缓冲区溢出
发布时间 2008-06-04 更新时间 2008-06-04
CVE编号 CVE-2008-1518 CNNVD-ID CNNVD-200806-089
漏洞平台 N/A CVSS评分 7.2
|漏洞来源
https://www.securityfocus.com/bid/29544
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200806-089
|漏洞详情
KasperskyInternetSecurity套件是一套完整的解决方案,用于保护计算机抵御几乎所有来自互联网的主要的威胁。InternetSecurity及其他Kaspersky产品中所发布的kl1.sys内核驱动在处理IOCTL0x800520e8时没有对向swprintf函数所传送的数据执行边界检查,在这种情况下目标缓冲区为2,000单元宽字符数据,因此如果源缓冲区超过了2000字符的话,就可以触发栈溢出,导致执行任意内核态指令。
|受影响的产品
Kaspersky Internet Security 7.0 Kaspersky Internet Security 6.0 Kaspersky Anti-Virus for Windows Workstation 6.0 Kaspersky Anti-Virus 7.0
|参考资料

来源:XF
名称:kaspersky-internetsecurity-kl1-bo(42849)
链接:http://xforce.iss.net/xforce/xfdb/42849
来源:www.kaspersky.com
链接:http://www.kaspersky.com/technews?id=203038727
来源:VUPEN
名称:ADV-2008-1739
链接:http://www.frsirt.com/english/advisories/2008/1739
来源:SECTRACK
名称:1020196
链接:http://securitytracker.com/id?1020196
来源:SECTRACK
名称:1020195
链接:http://securitytracker.com/id?1020195
来源:SECUNIA
名称:30534
链接:http://secunia.com/advisories/30534
来源:IDEFENSE
名称:20080604KasperskyInternetSecurityIOCTLStackBasedBufferOverflowVulnerability
链接:http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=704