GFL SDK 栈溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1187803 漏洞类型 缓冲区溢出
发布时间 2008-01-30 更新时间 2009-04-29
CVE编号 CVE-2008-0064 CNNVD-ID CNNVD-200801-470
漏洞平台 N/A CVSS评分 9.3
|漏洞来源
https://www.securityfocus.com/bid/27514
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200801-470
|漏洞详情
GFLSDK是XnView等程序所使用的函数库,用于提供图形格式支持。GFLSDK库在读取RadianceRGBE(*.hdr)文件时存在栈溢出漏洞,如果用户受骗查看了特制的RadianceRGBE文件的话,就可能触发这个溢出,导致执行任意指令。
|受影响的产品
XnView XnView Standard 1.92 XnView XnView Standard 1.91 XnView NConvert 4.85 XnView GFL SDK 2.870
|参考资料

来源:SECUNIA
名称:28326
链接:http://secunia.com/advisories/28326
来源:BID
名称:27514
链接:http://www.securityfocus.com/bid/27514
来源:VUPEN
名称:ADV-2008-0329
链接:http://www.frsirt.com/english/advisories/2008/0329
来源:VUPEN
名称:ADV-2008-0328
链接:http://www.frsirt.com/english/advisories/2008/0328
来源:MISC
链接:http://secunia.com/secunia_research/2008-1/advisory
来源:SECUNIA
名称:28710
链接:http://secunia.com/advisories/28710