Gimp PSD插件整数溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1189969 漏洞类型 边界条件错误
发布时间 2007-07-03 更新时间 2008-10-09
CVE编号 CVE-2007-2949 CNNVD-ID CNNVD-200707-057
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
https://www.securityfocus.com/bid/24745
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200707-057
|漏洞详情
GIMP(GNUImageManipulationProgram,GNU图像处理程序)是GIMP团队开发的一套跨平台的开源图像处理软件。该软件能够实现多种图像处理,包括照片润饰、图像合成和图像创建等。GIMP的plug-ins/common/psd.c文件中的seek_to_and_unpack_pixeldata()函数存在整数溢出漏洞,如果用户受骗打开了设置有超长高度和宽度值的特制PSD文件的话,就会触发堆溢出,导致执行任意指令。
|受影响的产品
Ubuntu Ubuntu Linux 7.04 sparc Ubuntu Ubuntu Linux 7.04 powerpc Ubuntu Ubuntu Linux 7.04 i386 Ubuntu Ubuntu Linux 7.04 amd64 Ubuntu Ubuntu Linux 6.10 sparc Ubuntu Ubuntu
|参考资料

来源:US-CERT
名称:VU#399896
链接:http://www.kb.cert.org/vuls/id/399896
来源:VUPEN
名称:ADV-2007-2421
链接:http://www.frsirt.com/english/advisories/2007/2421
来源:MISC
链接:http://secunia.com/secunia_research/2007-63/advisory/
来源:SECUNIA
名称:25677
链接:http://secunia.com/advisories/25677
来源:BID
名称:24745
链接:http://www.securityfocus.com/bid/24745
来源:svn.gnome.org
链接:http://svn.gnome.org/viewcvs/gimp?view=revision&revision=22798
来源:OVAL
名称:oval:org.mitre.oval:def:5772
链接:http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:5772
来源:issues.rpath.com
链接:https://issues.rpath.com/browse/RPL-1487
来源:XF
名称:gimp-unpackpixeldata-code-execution(35246)
链接:http://xforce.iss.net/xforce/xfdb/35246
来源:UBUNTU
名称:USN-480-1
链接:http://www.ubuntu.com/usn/usn-480-1
来源:SLACKWARE
名称:SSA:2007-222-01
链接:http://www.slackware.org/security/viewer.php?l=slackware-security&y=2007&m=slackware-security.360191
来源:REDHAT
名称:RHSA-2007:0513
链接:http://www.redhat.com/support/errata/RHSA-2007-0513.html
来源:SUSE
名称:SUSE-SR:2007: