PHP 5.2.6 'fastcgi.c' 缓存区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1190528 漏洞类型 缓冲区溢出
发布时间 2007-05-16 更新时间 2009-04-08
CVE编号 CVE-2008-2050 CNNVD-ID CNNVD-200805-023
漏洞平台 N/A CVSS评分 10.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200805-023
|漏洞详情
PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。PHP的5.2.6之前版本存在多个安全漏洞,允许恶意用户绕过安全限制、导致拒绝服务或入侵有漏洞的系统。FastCGISAPI(fastcgi.c)中的安全漏洞可能导致栈溢出。
|参考资料

来源:BID
名称:29009
链接:http://www.securityfocus.com/bid/29009
来源:www.php.net
链接:http://www.php.net/ChangeLog-5.php
来源:VUPEN
名称:ADV-2008-2268
链接:http://www.frsirt.com/english/advisories/2008/2268
来源:VUPEN
名称:ADV-2008-1412
链接:http://www.frsirt.com/english/advisories/2008/1412
来源:DEBIAN
名称:DSA-1572
链接:http://www.debian.org/security/2008/dsa-1572
来源:issues.rpath.com
链接:https://issues.rpath.com/browse/RPL-2503
来源:XF
名称:php-fastcgisapi-bo(42133)
链接:http://xforce.iss.net/xforce/xfdb/42133
来源:UBUNTU
名称:USN-628-1
链接:http://www.ubuntu.com/usn/usn-628-1
来源:BUGTRAQ
名称:20080523rPSA-2008-0176-1phpphp-cgiphp-imapphp-mcryptphp-mysqlphp-mysqliphp-pgsqlphp-soapphp-xslphp5php5-cgiphp5-imapphp5-mcryptphp5-mysqlphp5-mysqliphp5-pearphp5-pgsqlphp5-soapphp5-xsl
链接:http://www.securityfocus.com/archive/1/archive/1/492535/100/0/threaded
来源:MLIST
名称:[oss-security]20080502CVERequest(PHP)
链接:http://www.openwall.com/lists/oss-security/2008/05/02/2
来源:MANDRIVA
名称:MDVSA-2009:023
链接:http://www.mandriva.com/security/adviso