TCExam $_SERVER[] 'tce_config.php' 跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1190756 漏洞类型 跨站脚本
发布时间 2007-05-01 更新时间 2007-05-04
CVE编号 CVE-2007-2431 CNNVD-ID CNNVD-200705-003
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200705-003
|漏洞详情
TCExam的shared/config/tce_config.php中存在动态变量评估漏洞。远程攻击者可以通过修改重要的变量,比如$_SERVER,来执行跨站脚本攻击和可能其他攻击,比如借助_SERVER[SCRIPT_NAME]参数注入web脚本。
|参考资料

来源:sourceforge.net
链接:http://sourceforge.net/forum/forum.php?forum_id=690912
来源:MILW0RM
名称:3816
链接:http://www.milw0rm.com/exploits/3816
来源:VIM
名称:20070501TCExam-'XSS'isdynamicvariableevaluation;vendorpatch
链接:http://www.attrition.org/pipermail/vim/2007-May/001572.html
来源:XF
名称:tcexam-server-xss(33957)
链接:http://xforce.iss.net/xforce/xfdb/33957
来源:BID
名称:23704
链接:http://www.securityfocus.com/bid/23704
来源:SECUNIA
名称:25008
链接:http://secunia.com/advisories/25008