Linux Kernel RTA_MAX越界访问漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1190900 漏洞类型 输入验证
发布时间 2007-04-09 更新时间 2009-01-08
CVE编号 CVE-2007-2172 CNNVD-ID CNNVD-200704-393
漏洞平台 N/A CVSS评分 4.7
|漏洞来源
https://www.securityfocus.com/bid/23447
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200704-393
|漏洞详情
Linuxkernel是美国Linux基金会发布的开源操作系统Linux所使用的内核。NFSv4implementation是其中的一个分布式文件系统协议。LinuxKernel代码实现上存在漏洞,本地攻击可能利用此漏洞对系统造成拒绝服务。Linux内核代码中存在一个错误,将RTA_MAX而不是RTN_MAX错误地用做了数组的大小,导致dn_fib_props(dn_fib.c,DECNet)和fib_props(fib_semantics.c,IPv4)函数中可能出现越界访问的情况,造成内核崩溃。
|受影响的产品
Ubuntu Ubuntu Linux 7.04 sparc Ubuntu Ubuntu Linux 7.04 powerpc Ubuntu Ubuntu Linux 7.04 i386 Ubuntu Ubuntu Linux 7.04 amd64 Ubuntu Ubuntu Linux 6.10 sparc Ubuntu Ubuntu
|参考资料

来源:BID
名称:23447
链接:http://www.securityfocus.com/bid/23447
来源:UBUNTU
名称:USN-464-1
链接:http://www.ubuntu.com/usn/usn-464-1
来源:REDHAT
名称:RHSA-2008:0787
链接:http://www.redhat.com/support/errata/RHSA-2008-0787.html
来源:REDHAT
名称:RHSA-2007:1049
链接:http://www.redhat.com/support/errata/RHSA-2007-1049.html
来源:REDHAT
名称:RHSA-2007:0347
链接:http://www.redhat.com/support/errata/RHSA-2007-0347.html
来源:MANDRIVA
名称:MDKSA-2007:216
链接:http://www.mandriva.com/security/advisories?name=MDKSA-2007:216
来源:MANDRIVA
名称:MDKSA-2007:196
链接:http://www.mandriva.com/security/advisories?name=MDKSA-2007:196
来源:MANDRIVA
名称:MDKSA-2007:171
链接:http://www.mandriva.com/security/advisories?name=MDKSA-2007:171
来源:www.mail-archive.com
链接:http://www.mail-archive.com/git-commits-head@vger.kernel.org/msg08270.html
来源:www.mail-archive.com
链接:http://www.mail-archive.com/git-commits-head@vger.kernel.org/msg08269.html
来源:www.kernel.org
链接:http://www.kernel.org/pub/linux/kernel/v2.4/ChangeLog-2.4.35
来源:VUPEN
名称:ADV-2007-2690
链接:http://ww