HP-UX可移植文件系统远程缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1191015 漏洞类型 缓冲区溢出
发布时间 2007-04-12 更新时间 2009-03-31
CVE编号 CVE-2007-1993 CNNVD-ID CNNVD-200704-227
漏洞平台 N/A CVSS评分 9.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200704-227
|漏洞详情
HP-UX是一款HP公司开发的UNIX操作系统。HP-UX的可移植文件系统(PFS)的畸形请求的处理上存在漏洞,远程攻击者可能利用此漏洞在服务器上执行任意指令。PFS允许加载各种CD-ROM磁盘,pfs_mountd.rpc守护程序是与pfsd一起启动的RPC扩展,以便在HP-UX下加载各种文件系统。如果攻击者通过UDP向pfs_mountd.rpc发送了两个特制报文,其中一个报文首先调用过程5,然后马上向过程2发送实际的攻击负载,就可以触发缓冲区溢出,导致在用户系统上执行任意指令。
|参考资料

来源:VUPEN
名称:ADV-2007-1343
链接:http://www.frsirt.com/english/advisories/2007/1343
来源:HP
名称:SSRT071339
链接:http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00913684
来源:SECTRACK
名称:1017893
链接:http://www.securitytracker.com/id?1017893
来源:BID
名称:23401
链接:http://www.securityfocus.com/bid/23401
来源:SECUNIA
名称:24855
链接:http://secunia.com/advisories/24855
来源:OVAL
名称:oval:org.mitre.oval:def:5751
链接:http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:5751
来源:IDEFENSE
名称:20070412HewlettPackardHP-UXRemotepfs_mountd.rpcBufferOverflowVulnerability
链接:http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=512