NetBSD ISO(4) 缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1191174 漏洞类型 缓冲区溢出
发布时间 2007-03-29 更新时间 2007-03-29
CVE编号 CVE-2007-1677 CNNVD-ID CNNVD-200703-666
漏洞平台 N/A CVSS评分 6.6
|漏洞来源
https://www.securityfocus.com/bid/23193
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200703-666
|漏洞详情
NetBSD内核2.0到4.0_BETA2版本和NetBSD-current20070329之前的版本中的ISO网络协议支持存在缓冲区溢出漏洞。本地用户可以借助提交到特定函数的长参数,比如提交到clnp_route函数的长的sockaddr结构参数,执行任意代码。
|受影响的产品
NetBSD NetBSD 3.0.2 NetBSD NetBSD 3.0.1 NetBSD NetBSD 2.1 NetBSD NetBSD 2.0.3 NetBSD NetBSD 2.0.2 NetBSD NetBSD 2.0.1 NetBSD NetBSD 2.0
|参考资料

来源:BID
名称:23193
链接:http://www.securityfocus.com/bid/23193
来源:OSVDB
名称:43596
链接:http://osvdb.org/43596
来源:NETBSD
名称:NetBSD-SA2007-004
链接:ftp://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2007-004.txt.asc
来源:SECTRACK
名称:1017832
链接:http://www.securitytracker.com/id?1017832
来源:VUPEN
名称:ADV-2007-1159
链接:http://www.frsirt.com/english/advisories/2007/1159