PostgreSQL query planner拒绝服务漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1191837 漏洞类型 其他
发布时间 2007-02-05 更新时间 2007-02-06
CVE编号 CVE-2007-0556 CNNVD-ID CNNVD-200702-064
漏洞平台 N/A CVSS评分 6.6
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200702-064
|漏洞详情
PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。PostgreSQL中的查询计划程序(queryplanner)没有验证表格是否与之前所执行的查询计划兼容,允许远程已认证的攻击者通过"ALTERCOLUMNTYPE"SQL语句导致服务器崩溃;理论上攻击者也可以利用这个漏洞读取数据的内容。
|参考资料

来源:VUPEN
名称:ADV-2007-0478
链接:http://www.frsirt.com/english/advisories/2007/0478
来源:UBUNTU
名称:USN-417-1
链接:http://www.ubuntulinux.org/support/documentation/usn/usn-417-1
来源:www.postgresql.org
链接:http://www.postgresql.org/support/security
来源:SECUNIA
名称:24033
链接:http://secunia.com/advisories/24033
来源:OSVDB
名称:33302
链接:http://osvdb.org/33302
来源:issues.rpath.com
链接:https://issues.rpath.com/browse/RPL-830
来源:issues.rpath.com
链接:https://issues.rpath.com/browse/RPL-1025
来源:XF
名称:postgresql-datatype-information-disclosure(32191)
链接:http://xforce.iss.net/xforce/xfdb/32191
来源:UBUNTU
名称:USN-417-2
链接:http://www.ubuntu.com/usn/usn-417-2
来源:TRUSTIX
名称:2007-0007
链接:http://www.trustix.org/errata/2007/0007
来源:BID
名称:22387
链接:http://www.securityfocus.com/bid/22387
来源:BUGTRAQ
名称:20070208rPSA-2007-0025-2postgresqlpostgresql-server
链接:http://www.securityfocus.com/archive/1/archive/1/459448/100/0/threaded
来源:BUGTRAQ
名称:20070206rPSA-2007-0025-1postgresqlpostgresql-server
链接:http://www.securityfocus.com/archi