LedgerSMB和QL-Ledger重定向函数 远程代码执行漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1191861 漏洞类型 边界条件错误
发布时间 2007-03-05 更新时间 2007-03-06
CVE编号 CVE-2007-0667 CNNVD-ID CNNVD-200702-019
漏洞平台 N/A CVSS评分 6.5
|漏洞来源
https://www.securityfocus.com/bid/22828
https://cxsecurity.com/issue/WLB-2007020022
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200702-019
|漏洞详情
(1)LedgerSMB版本之前的版本1.1.5版本和(2)SQL-Ledger的Form.pm中的重定向函数允许远程验证用户可以借助与回叫信号相关的重定向,执行任意代码。该漏洞不同于CVE-2006-5872。
|漏洞EXP
Separate from CVE-2006-5872, there is a possibility of causing arbitrary 
code execution during redirects.  This requires a valid login to exploit 
and was discovered and brought to the attention of both the SQL-Ledger 
and LedgerSMB team in November.  LedgerSMB 1.1.5 corred the problem, but 
it is still not corrected in SQL-Ledger.

There is no workaround to prevent the problem except to hope that those 
who are using vulnerable software can be trusted.

I will be sending a full disclosure of the problem, as well as an 
unofficial patch to SQL-Ledger in a week.

Best Wishes,
Chris Travers
Metatron Technology Consulting
begin:vcard
fn:Chris Travers
n:Travers;Chris
email;internet:chris (at) metatrontech (dot) com [email concealed]
tel;work:509-888-0220
tel;cell:509-630-7794
x-mozilla-html:FALSE
version:2.1
end:vcard
|受影响的产品
SQL-Ledger SQL-Ledger 2.6.21 SQL-Ledger SQL-Ledger 2.6.19 SQL-Ledger SQL-Ledger 2.6.18 SQL-Ledger SQL-Ledger 2.6.17 SQL-Ledger SQL-Ledger 2.4.7 LedgerSMB LedgerSMB 1.1
|参考资料

来源:VUPEN
名称:ADV-2007-0407
链接:http://www.frsirt.com/english/advisories/2007/0407
来源:BID
名称:22295
链接:http://www.securityfocus.com/bid/22295
来源:BUGTRAQ
名称:20070206UnofficialSQL-LedgerpatchforCVE-2007-0667
链接:http://www.securityfocus.com/archive/1/archive/1/459264/100/0/threaded
来源:BUGTRAQ
名称:20070127ArbitraryCodeExecutioninSQL-LedgerandLedgerSMBthroughredirects
链接:http://www.securityfocus.com/archive/1/archive/1/458464/100/0/threaded
来源:SREASON
名称:2217
链接:http://securityreason.com/securityalert/2217