QuickCam Linux设备驱动QCAMVC_Video_Init函数缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1192308 漏洞类型 边界条件错误
发布时间 2006-12-31 更新时间 2007-01-04
CVE编号 CVE-2006-6854 CNNVD-ID CNNVD-200612-642
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200612-642
|漏洞详情
QuickCam是Logitech罗技公司的摄像头产品。QuickCam的Linux驱动的初始化函数qcamvc_video_init中存在缓冲区溢出漏洞,本地攻击者可能利用此漏洞造成拒绝服务或控制系统。qcamvc_video_init函数的原型如下:staticvoidqcamvc_video_init(structqcamvc*qcamvc)如果用户使用了特制的QuickCam对象的话,就会触发这个溢出,导致执行任意指令。
|参考资料

来源:BID
名称:21815
链接:http://www.securityfocus.com/bid/21815
来源:BUGTRAQ
名称:20061229QuickCamlinuxdevicedriverallowsarbitrarycodeexecution
链接:http://www.securityfocus.com/archive/1/archive/1/455487/100/0/threaded
来源:XF
名称:quickcam-driver-code-execution(31211)
链接:http://xforce.iss.net/xforce/xfdb/31211
来源:NSFOCUS
名称:9759
链接:http://www.nsfocus.net/vulndb/9759