Xsupplicant eap_do_notify()函数远程栈溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1193026 漏洞类型 缓冲区溢出
发布时间 2006-10-27 更新时间 2007-01-25
CVE编号 CVE-2006-5601 CNNVD-ID CNNVD-200610-511
漏洞平台 N/A CVSS评分 9.0
|漏洞来源
https://www.securityfocus.com/bid/20775
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200610-511
|漏洞详情
Xsupplicant是802.1X/WPA/WPA2/IEEE802.11i协议的开放源码实现。Xsupplicant的eap_do_notify()函数的实现上存在栈溢出漏洞,远程攻击者可能利用此漏洞在服务器上执行任意指令。远程攻击者可以通过发送特制的EAP报文导致以root用户权限执行任意指令,失败的攻击也可能导致拒绝服务。
|受影响的产品
SuSE SUSE Linux Enterprise Server 9 SP3 S.u.S.E. openSUSE 10.2 S.u.S.E. Linux Professional 10.0 OSS S.u.S.E. Linux Professional 10.0 S.u.S.E. Linux Professional 9.3 x86_64
|参考资料

来源:BID
名称:20775
链接:http://www.securityfocus.com/bid/20775
来源:MANDRIVA
名称:MDKSA-2006:189
链接:http://frontal2.mandriva.com/security/advisories?name=MDKSA-2006:189
来源:VUPEN
名称:ADV-2006-4233
链接:http://www.frsirt.com/english/advisories/2006/4233
来源:SECUNIA
名称:22641
链接:http://secunia.com/advisories/22641
来源:SECUNIA
名称:22612
链接:http://secunia.com/advisories/22612
来源:open1x.cvs.sourceforge.net
链接:http://open1x.cvs.sourceforge.net/open1x/xsupplicant/src/eap.c?r1=1.135&r2=1.136
来源:XF
名称:xsupplicant-eapdo-bo(29902)
链接:http://xforce.iss.net/xforce/xfdb/29902
来源:SUSE
名称:SUSE-SR:2007:001
链接:http://www.novell.com/linux/security/advisories/2007_01_sr.html
来源:MANDRIVA
名称:MDKSA-2006:189
链接:http://www.mandriva.com/security/advisories?name=MDKSA-2006:189