phpAdsNew and phpPgAds 'lib-history.inc.php'跨站脚本攻击漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1193050 漏洞类型 跨站脚本
发布时间 2006-10-26 更新时间 2006-10-26
CVE编号 CVE-2006-5515 CNNVD-ID CNNVD-200610-472
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
https://www.securityfocus.com/bid/83600
https://cxsecurity.com/issue/WLB-2006100139
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200610-472
|漏洞详情
phpAdsNewandphpPgAds2.0.8-pr1之前版本的lib-history.inc.php中存在跨站脚本攻击漏洞,远程攻击者可以通过不明向量(与通过delivery脚本存储的以及通过admin界面显示的注入数据相关)来注入任意Web脚本或HTML。
|漏洞EXP
========================================================================

phpAdsNew / phpPgAds security advisory             PHPADSNEW-SA-2006-002
------------------------------------------------------------------------

Advisory ID:               PHPADSNEW-SA-2006-002
Date:                      2006-Oct-28
Security risk:             medium risk
Applications affected:     phpAdsNew, phpPgAds
Applications not affected: Max Media Manager v0.1.x - v0.3.x
Versions affected:         <= 2.0.8
Versions not affected:     >= 2.0.8-pr1
========================================================================

========================================================================

Vulnerability:  HTML injection / Cross-site scripting
========================================================================

Description
-----------
Some scripts inside the admin interface were displaying parameters
collected by the delivery scripts without proper sanitizing or escaping.
The delivery scripts have public access, while the admin interface is
restricted to logged in users. An attacker could inject HTML/XSS code
which could be displayed/executed in a later time inside the admin
interface.

Solutions
---------
- Upgrade to phpAdsNew or phpPgAds 2.0.8-pr1.

Contact informations
====================

The security contact for phpAdsNew and phpPgAds can be reached at:
<security AT phpadsnew DOT com>

Best regards
-- 
Matteo Beccati
http://phpadsnew.com
http://phppgads.com
|受影响的产品
phpPgAds phpPgAds 2.0.8 phpAdsNew phpAdsNew 2.0.8
|参考资料

来源:VUPEN
名称:ADV-2006-4147
链接:http://www.frsirt.com/english/advisories/2006/4147
来源:BUGTRAQ
名称:20061023[PHPADSNEW-SA-2006-002]phpAdsNewandphpPgAds2.0.8-pr1fixXSSvulnerability
链接:http://www.securityfocus.com/archive/1/archive/1/449484/100/0/threaded
来源:VUPEN
名称:ADV-2006-4148
链接:http://www.frsirt.com/english/advisories/2006/4148
来源:sourceforge.net
链接:http://sourceforge.net/project/shownotes.php?release_id=457775&group_id=36679
来源:sourceforge.net
链接:http://sourceforge.net/project/shownotes.php?release_id=457774&group_id=11386
来源:SECUNIA
名称:22529
链接:http://secunia.com/advisories/22529
来源:SECUNIA
名称:22526
链接:http://secunia.com/advisories/22526
来源:XF
名称:phpadsnew-libhistory-xss(29766)
链接:http://xforce.iss.net/xforce/xfdb/29766
来源:SREASON
名称:1777
链接:http://securityreason.com/securityalert/1777