PHP 第三方会话句柄的会话标识符设计限制

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1193693 漏洞类型 未知
发布时间 2006-08-28 更新时间 2006-08-28
CVE编号 CVE-2006-4433 CNNVD-ID CNNVD-200608-461
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
https://www.securityfocus.com/bid/83314
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200608-461
|漏洞详情
PHP4.4.3之前版本和5.1.4之前的5.x版本没有对第三方会话句柄的会话标识符(PHPSESSID)的字符集进行限制,这样,远程攻击者通过将PHP代码插入到存储在会话文件中的会话标识符PHPSESSID中,从而利用其它漏洞会更加容易实现。注:此问题在PHP内部并不属于漏洞,而是一种设计限制,但这一观点存在争议。致使某些抵制会话句柄的攻击得以存在,便不能为这种限制做出解释。
|受影响的产品
PHP PHP 5.1.2 + Ubuntu Ubuntu Linux 6.06 LTS sparc + Ubuntu Ubuntu Linux 6.06 LTS powerpc + Ubuntu Ubuntu Linux 6.
|参考资料

来源:BUGTRAQ
名称:20060824Advisory05/2006:ZendPlatformMultipleRemoteVulnerabilities
链接:http://www.securityfocus.com/archive/1/archive/1/444263/100/0/threaded
来源:MISC
链接:http://www.hardened-php.net/advisory_052006.128.html
来源:VUPEN
名称:ADV-2006-3388
链接:http://www.frsirt.com/english/advisories/2006/3388
来源:SECUNIA
名称:21573
链接:http://secunia.com/advisories/21573
来源:OSVDB
名称:28273
链接:http://www.osvdb.org/28273
来源:OSVDB
名称:28233
链接:http://www.osvdb.org/28233
来源:SREASON
名称:1466
链接:http://securityreason.com/securityalert/1466