FCKeditor upload.php 输入验证漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1194929 漏洞类型 输入验证
发布时间 2006-05-22 更新时间 2006-05-23
CVE编号 CVE-2006-2529 CNNVD-ID CNNVD-200605-393
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200605-393
|漏洞详情
FCKditor是一款开放源码的HTML文本编辑器。FCKeditor在处理文件上传时存在输入验证错误,远程攻击可能利用此漏洞上传任意文件。在通过editor/filemanager/upload/php/upload.php上传文件时攻击者可以通过为Type参数定义无效的值导致上传任意脚本。成功攻击要求config.php配置文件中启用的文件上传,而默认是禁用的。
|参考资料

来源:BID
名称:18029
链接:http://www.securityfocus.com/bid/18029
来源:VUPEN
名称:ADV-2006-1856
链接:http://www.frsirt.com/english/advisories/2006/1856
来源:www.fckeditor.net
链接:http://www.fckeditor.net/whatsnew/default.html
来源:SECUNIA
名称:20122
链接:http://secunia.com/advisories/20122
来源:OSVDB
名称:25631
链接:http://www.osvdb.org/25631