X7 Chat 头像URL 跨站脚本攻击(XSS)漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1195085 漏洞类型 跨站脚本
发布时间 2006-05-09 更新时间 2006-05-10
CVE编号 CVE-2006-2282 CNNVD-ID CNNVD-200605-139
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
https://cxsecurity.com/issue/WLB-2006050056
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200605-139
|漏洞详情
X7Chat2.0.2及之前版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助头像的URL中的javascriptURI,注入任意Web脚本或HTML,可能与register.php中的avatar参数有关。
|漏洞EXP
X7Chat <= 2.0.2 avatar XSS injection

Discovered by: Nomenumbra

Date: 6/4/2006

impact:moderate (privilege escalation,possible defacement)

X7Chat versions 2.0.2 and below are prone to XSS injection in a user's avatar.

By setting this as the url of your avatar:

javascript:alert('xss')

you'd have some good ol' XSS

Nomenumbra/[0x4F4C]
|参考资料

来源:BID
名称:17869
链接:http://www.securityfocus.com/bid/17869
来源:BUGTRAQ
名称:20060506X7Chat<=2.0.2avatarXSSinjection
链接:http://www.securityfocus.com/archive/1/archive/1/433131/100/0/threaded
来源:OSVDB
名称:25303
链接:http://www.osvdb.org/25303
来源:VUPEN
名称:ADV-2006-1702
链接:http://www.frsirt.com/english/advisories/2006/1702
来源:SECUNIA
名称:20007
链接:http://secunia.com/advisories/20007
来源:XF
名称:x7chat-avatar-xss(26327)
链接:http://xforce.iss.net/xforce/xfdb/26327
来源:SREASON
名称:859
链接:http://securityreason.com/securityalert/859