Sun Solaris libpkcs11本地权限提升漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1195187 漏洞类型 设计错误
发布时间 2006-04-27 更新时间 2006-04-28
CVE编号 CVE-2006-2064 CNNVD-ID CNNVD-200604-532
漏洞平台 N/A CVSS评分 4.6
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200604-532
|漏洞详情
Solaris是一款由Sun开发和维护的商业性质UNIX操作系统。Solaris系统的libpkcs11(3LIB)库实现上存在漏洞,本地攻击者可能利用此漏洞提升权限。如果特权应用程序链接到libpkcs11(3LIB)库且使用非重入函数的getpwnam(3C)家族获得口令项的话,本地非特权用户就可以以应用程序的权限执行任意代码,具体取决于应用程序使用getpwnam(3C)所提供数据及相关函数的方法。应用程序也可能由于从非重入getpwnam(3C)函数收到非预期的数据而失效。
|参考资料

来源:BID
名称:17687
链接:http://www.securityfocus.com/bid/17687
来源:VUPEN
名称:ADV-2006-1504
链接:http://www.frsirt.com/english/advisories/2006/1504
来源:SUNALERT
名称:102316
链接:http://sunsolve.sun.com/search/document.do?assetkey=1-26-102316-1
来源:SECTRACK
名称:1015987
链接:http://securitytracker.com/id?1015987
来源:SECUNIA
名称:19789
链接:http://secunia.com/advisories/19789
来源:XF
名称:solaris-libpkcs11-privilege-escalation(26075)
链接:http://xforce.iss.net/xforce/xfdb/26075