OpenVPN LD_PRELOAD环境变量传输漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1195491 漏洞类型 输入验证
发布时间 2006-04-06 更新时间 2006-12-05
CVE编号 CVE-2006-1629 CNNVD-ID CNNVD-200604-073
漏洞平台 N/A CVSS评分 9.0
|漏洞来源
https://www.securityfocus.com/bid/17392
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200604-073
|漏洞详情
OpenVPN是美国OpenVPN公司的一个用于创建虚拟专用网络(VPN)加密通道的软件包,它使用OpenSSL库来加密数据与控制信息,并允许创建的VPN使用公开密钥、电子证书或者用户名/密码来进行身份验证。OpenVPN客户端允许服务器通过"setenv"配置指令向客户端shell传送包括LD_PRELOAD在内的环境变量。攻击者可以在已知位置放置恶意文件并加载该文件来执行任意代码。
|受影响的产品
S.u.S.E. Linux Professional 10.0 OSS S.u.S.E. Linux Professional 10.0 S.u.S.E. Linux Professional 9.3 x86_64 S.u.S.E. Linux Professional 9.3 S.u.S.E. Linux Personal 10.0 OSS
|参考资料

来源:BID
名称:17392
链接:http://www.securityfocus.com/bid/17392
来源:VUPEN
名称:ADV-2006-1261
链接:http://www.frsirt.com/english/advisories/2006/1261
来源:SECUNIA
名称:19531
链接:http://secunia.com/advisories/19531
来源:openvpn.net
链接:http://openvpn.net/changelog.html
来源:MISC
链接:http://www.osreviews.net/reviews/security/openvpn-print
来源:sourceforge.net
链接:http://sourceforge.net/mailarchive/forum.php?thread_id=10093825&forum_id=8482
来源:XF
名称:openvpn-ldpreload-code-execution(25667)
链接:http://xforce.iss.net/xforce/xfdb/25667
来源:OSVDB
名称:24444
链接:http://www.osvdb.org/24444
来源:SUSE
名称:SUSE-SR:2006:009
链接:http://www.novell.com/linux/security/advisories/2006_04_28.html
来源:MANDRIVA
名称:MDKSA-2006:069
链接:http://www.mandriva.com/security/advisories?name=MDKSA-2006:069
来源:DEBIAN
名称:DSA-1045
链接:http://www.debian.org/security/2006/dsa-1045
来源:SECUNIA
名称:19897
链接:http://secunia.com/advisories/19897
来源:SECUNIA
名称:19837
链接:http://secunia.com/advisories/19837
来源:SECUNIA
名称:19598
链接:http://secunia.com/advisories/19598
来源:M