GNU BinUtils GAS缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1196474 漏洞类型 缓冲区溢出
发布时间 2005-12-31 更新时间 2006-08-21
CVE编号 CVE-2005-4808 CNNVD-ID CNNVD-200512-972
漏洞平台 N/A CVSS评分 7.6
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200512-972
|漏洞详情
GNUBinutils(又名GNUBinaryUtilities或binutils)是GNU计划开发的一组编程语言工具程序,它主要用于处理多种格式的目标文件,并提供有连接器、汇编器和其他用于目标文件和档案的工具。GNUBinUtils的gas(GNU汇编器)中存在缓冲区溢出漏洞,本地攻击者可能利用此漏洞提升自己的权限s。如果用户或自动系统受骗使用gcc或gas汇编了特制的源文件的话,就可能导致以执行用户权限执行任意指令。
|参考资料

来源:sources.redhat.com
链接:http://sources.redhat.com/bugzilla/show_bug.cgi?id=1069
来源:XF
名称:binutils-resetvars-bo(44661)
链接:http://xforce.iss.net/xforce/xfdb/44661
来源:UBUNTU
名称:USN-366-1
链接:http://www.ubuntu.com/usn/usn-366-1
来源:NSFOCUS
名称:9178
链接:http://www.nsfocus.net/vulndb/9178