FFmpeg LibAVCodec堆溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1197039 漏洞类型 缓冲区溢出
发布时间 2005-12-06 更新时间 2007-01-04
CVE编号 CVE-2005-4048 CNNVD-ID CNNVD-200512-133
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
https://www.securityfocus.com/bid/15743
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200512-133
|漏洞详情
FFmpeg是一套对音频和视频进行解码录制转换的完整的方案。FFmpeg在处理小图像时存在溢出漏洞,攻击者可能利用此漏洞在主机上执行任意指令。FFmpeg的libavcodec库在解码很小的(如1x1)PIX_FMT_PAL8格式图形时存在堆溢出漏洞。get_buffer函数avcodec_default_get_buffer不能为palette项分配足够的空间,因此如果将palette数据拷贝到了data[1]数组中,就会溢出堆缓冲区,导致分段错误。攻击者可以诱骗用户使用调用有漏洞版本libavcodec的应用程序打开畸形的PNG文件。如果该程序配置为PNG文件的默认处理器的话,就会在用户系统上执行任意代码。
|受影响的产品
VLC VLC 0.8.5 VLC VLC 0.8.4 VLC VLC 0.8.1 Ubuntu Ubuntu Linux 5.10 powerpc Ubuntu Ubuntu Linux 5.10 i386 Ubuntu Ubuntu Linux 5.10 amd64 Ubuntu Ubuntu Lin
|参考资料

来源:BID
名称:15743
链接:http://www.securityfocus.com/bid/15743
来源:VUPEN
名称:ADV-2005-2770
链接:http://www.frsirt.com/english/advisories/2005/2770
来源:SECUNIA
名称:17892
链接:http://secunia.com/advisories/17892
来源:www1.mplayerhq.hu
链接:http://www1.mplayerhq.hu/cgi-bin/cvsweb.cgi/ffmpeg/libavcodec/utils.c?rev=1.162&content-type=text/x-cvsweb-markup&cvsroot=FFMpeg
来源:www1.mplayerhq.hu
链接:http://www1.mplayerhq.hu/cgi-bin/cvsweb.cgi/ffmpeg/libavcodec/utils.c.diff?r1=1.161&r2=1.162&cvsroot=FFMpeg
来源:DEBIAN
名称:DSA-992
链接:http://www.us.debian.org/security/2006/dsa-992
来源:UBUNTU
名称:USN-230-2
链接:http://www.ubuntulinux.org/support/documentation/usn/usn-230-2
来源:UBUNTU
名称:USN-230-1
链接:http://www.ubuntulinux.org/support/documentation/usn/usn-230-1
来源:GENTOO
名称:GLSA-200603-03
链接:http://www.gentoo.org/security/en/glsa/glsa-200603-03.xml
来源:GENTOO
名称:GLSA-200602-01
链接:http://www.gentoo.org/security/en/glsa/glsa-200602-01.xml
来源:GENTOO
名称:GLSA-200601-06
链接:http://www.gentoo.org/security/en/glsa/glsa-200601-06.xml