Inkscape不安全的临时文件创建漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1197147 漏洞类型 设计错误
发布时间 2005-08-09 更新时间 2006-04-17
CVE编号 CVE-2005-3885 CNNVD-ID CNNVD-200511-438
漏洞平台 N/A CVSS评分 2.1
|漏洞来源
https://www.securityfocus.com/bid/14522
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200511-438
|漏洞详情
inkscape是一个开放原始码的向量绘图软件,而且功能也十分强大,除了基本的点、线、面、圆形、矩形、曲线之外,也可以做到三维颜色等等高级功能。Inkscape0.41之前版本中的ps2epsi扩展shell脚本(ps2epsi.sh),可让本地用户通过对tmpepsifile.epsi临时文件的符号链接攻击覆盖任意文件。
|受影响的产品
Inkscape Inkscape 0.41 Inkscape Inkscape 0.40 + Ubuntu Ubuntu Linux 5.0 4 powerpc + Ubuntu Ubuntu Linux 5.0 4 i386
|参考资料

来源:BID
名称:14522
链接:http://www.securityfocus.com/bid/14522
来源:bugs.debian.org
链接:http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=321501
来源:UBUNTU
名称:USN-223-1
链接:http://www.ubuntulinux.org/support/documentation/usn/usn-223-1
来源:DEBIAN
名称:DSA-916
链接:http://www.debian.org/security/2005/dsa-916
来源:SECUNIA
名称:17886
链接:http://secunia.com/advisories/17886
来源:SECUNIA
名称:17882
链接:http://secunia.com/advisories/17882
来源:SECUNIA
名称:16343
链接:http://secunia.com/advisories/16343