PHP exif_read_data函数拒绝服务漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1197292 漏洞类型 设计错误
发布时间 2005-11-08 更新时间 2007-01-15
CVE编号 CVE-2005-3353 CNNVD-ID CNNVD-200511-239
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
https://www.securityfocus.com/bid/15358
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200511-239
|漏洞详情
PHP是一种易于学习和使用的服务器端脚本语言。PHP4.4.1以前的版本中,其Exif模块中的exif_read_data函数允许远程攻击者通过一个特制的JPEG图像来导致拒绝服务攻击。
|受影响的产品
Ubuntu Ubuntu Linux 5.10 powerpc Ubuntu Ubuntu Linux 5.10 i386 Ubuntu Ubuntu Linux 5.10 amd64 Ubuntu Ubuntu Linux 5.0 4 powerpc Ubuntu Ubuntu Linux 5.0 4 i386 Ubuntu Ubuntu
|参考资料

来源:US-CERT
名称:TA06-062A
链接:http://www.us-cert.gov/cas/techalerts/TA06-062A.html
来源:MISC
链接:http://bugs.php.net/bug.php?id=34704
来源:UBUNTU
名称:USN-232-1
链接:http://www.ubuntulinux.org/usn/usn-232-1/document_view
来源:BID
名称:15358
链接:http://www.securityfocus.com/bid/15358
来源:SUSE
名称:SUSE-SA:2005:069
链接:http://www.securityfocus.com/archive/1/archive/1/419504/100/0/threaded
来源:www.php.net
链接:http://www.php.net/ChangeLog-4.php#4.4.1
来源:OPENPKG
名称:OpenPKG-SA-2005.027
链接:http://www.openpkg.org/security/OpenPKG-SA-2005.027-php.html
来源:FEDORA
名称:FLSA:166943
链接:http://www.fedoralegacy.org/updates/FC2/2005-11-28-FLSA_2005_166943__Updated_php_packages_fix_security_issues.html
来源:SECUNIA
名称:18198
链接:http://secunia.com/advisories/18198
来源:SECUNIA
名称:18054
链接:http://secunia.com/advisories/18054
来源:SECUNIA
名称:17371
链接:http://secunia.com/advisories/17371
来源:REDHAT
名称:RHSA-2005:831
链接:http://rhn.redhat.com/errata/RHSA-2005-831.html
来源:MANDRIVA
名称:MDKSA-2005:213
链接:http://frontal2.mandriva.com/security/advi