PHP Apache 2 Virtual() Safe_Mode和Open_Basedir限制绕过漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1197448 漏洞类型 Unknown
发布时间 2005-11-14 更新时间 2006-11-02
CVE编号 CVE-2005-3392 CNNVD-ID CNNVD-200511-038
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
https://www.securityfocus.com/bid/15413
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200511-038
|漏洞详情
PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。Apache2上的PHP在调用virtual()时存在漏洞,本地攻击者可以绕过safe_mode和open_basedir保护机制,非授权访问敏感信息。
|受影响的产品
Ubuntu Ubuntu Linux 5.10 powerpc Ubuntu Ubuntu Linux 5.10 i386 Ubuntu Ubuntu Linux 5.10 amd64 Ubuntu Ubuntu Linux 5.0 4 powerpc Ubuntu Ubuntu Linux 5.0 4 i386 Ubuntu Ubuntu
|参考资料

来源:US-CERT
名称:TA06-062A
链接:http://www.us-cert.gov/cas/techalerts/TA06-062A.html
来源:www.php.net
链接:http://www.php.net/release_4_4_1.php
来源:VUPEN
名称:ADV-2005-2254
链接:http://www.frsirt.com/english/advisories/2005/2254
来源:SECUNIA
名称:17371
链接:http://secunia.com/advisories/17371
来源:XF
名称:php-virtual-bypass-security(22924)
链接:http://xforce.iss.net/xforce/xfdb/22924
来源:UBUNTU
名称:USN-232-1
链接:http://www.ubuntulinux.org/usn/usn-232-1/document_view
来源:BID
名称:16907
链接:http://www.securityfocus.com/bid/16907
来源:BID
名称:15413
链接:http://www.securityfocus.com/bid/15413
来源:SUSE
名称:SUSE-SA:2005:069
链接:http://www.securityfocus.com/archive/1/archive/1/419504/100/0/threaded
来源:OSVDB
名称:20897
链接:http://www.osvdb.org/20897
来源:GENTOO
名称:GLSA-200511-08
链接:http://www.gentoo.org/security/en/glsa/glsa-200511-08.xml
来源:VUPEN
名称:ADV-2006-4320
链接:http://www.frsirt.com/english/advisories/2006/4320
来源:VUPEN
名称:ADV-2006-0791
链接:http://www.frsirt.com/english/advisories/2006/0791
来源:SREASON
名称:525
链接:http://securityreason