Nokia Affix 蓝牙协议栈权限提升漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1199781 漏洞类型 未知
发布时间 2005-04-24 更新时间 2005-04-24
CVE编号 CVE-2005-1294 CNNVD-ID CNNVD-200504-089
漏洞平台 N/A CVSS评分 7.2
|漏洞来源
https://www.securityfocus.com/bid/90096
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200504-089
|漏洞详情
Affix是Nokia开发的Linux下的蓝牙通讯堆栈,基于GPL发布。Affix支持核心蓝牙协议包括:HCI,L2CAP1.1,L2CAP1.2,RFCOMM,SDP等。用于Linux的Affix蓝牙协议栈内的affix_sock_register使得本地用户可能通过套接字调用且这种调用带有作为数组索引的负协议值来获取权限。
|受影响的产品
Nokia Affix 3.2
|参考资料

来源:affix.sourceforge.net
链接:http://affix.sourceforge.net/patch_hci_3_2_0
来源:MISC
链接:http://www.digitalmunition.com/DMA%5B2005-0423a%5D.txt
来源:BUGTRAQ
名称:20050424DMA[2005-0423a]-'NokiaAffixBluetoothIntegerUnderflow'
链接:http://marc.theaimsgroup.com/?l=bugtraq&m=111445064725591&w=2