IglooFTP ftplist.c 文件覆盖漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1200284 漏洞类型 未知
发布时间 2005-01-10 更新时间 2005-01-10
CVE编号 CVE-2004-1277 CNNVD-ID CNNVD-200501-176
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
https://www.securityfocus.com/bid/90538
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200501-176
|漏洞详情
IglooFTP是一款FTP客户端软件。IglooFTP0.6.1版本中存在文件覆盖漏洞。由于ftplist.c的download_selection_recursive()函数存在缺陷,远程恶意FTP服务器可通过包含"/"的文件名,重写任意文件。
|受影响的产品
IglooFTP IglooFTP 0.6.1
|参考资料

来源:XF
名称:iglooftp-file-overwrite(18561)
链接:http://xforce.iss.net/xforce/xfdb/18561
来源:MISC
链接:http://tigger.uic.edu/~jlongs2/holes/iglooftp2.txt