Cherokee cherokee_logger_ncsa_write_string 格式串漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1200335 漏洞类型 格式化字符串
发布时间 2005-01-10 更新时间 2005-10-20
CVE编号 CVE-2004-1097 CNNVD-ID CNNVD-200501-055
漏洞平台 N/A CVSS评分 10.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200501-055
|漏洞详情
Cherokee是一款Web服务器,它支持HTTP负载平衡、日志记录和HTTP反向代理等。Cherokee0.4.17及之前版本的cherokee_logger_ncsa_write_string函数中存在格式化字符串漏洞。通过auth_pam进行验证时,远程攻击者可以借助URL中的格式化字符串,造成拒绝服务(应用程序崩溃)并可能执行任意代码。
|参考资料

来源:BID
名称:11574
链接:http://www.securityfocus.com/bid/11574
来源:GENTOO
名称:GLSA-200411-02
链接:http://www.gentoo.org/security/en/glsa/glsa-200411-02.xml
来源:XF
名称:cherokee-format-string(17934)
链接:http://xforce.iss.net/xforce/xfdb/17934
来源:MISC
链接:http://bugs.gentoo.org/show_bug.cgi?id=67667