phpBB HTTP应答分割攻击及跨站脚本执行漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1201516 漏洞类型 输入验证
发布时间 2004-07-19 更新时间 2005-10-20
CVE编号 CVE-2004-2055 CNNVD-ID CNNVD-200407-037
漏洞平台 N/A CVSS评分 4.3
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200407-037
|漏洞详情
phpBB是一款由PHP编写的WEB论坛应用程序,支持多种数据库系统,可使用在多种Unix和Linux操作系统下。phpBB的多个脚本存在HTTP应答分割攻击或者跨站脚本攻击,远程攻击者可以利用这个漏洞进行WEB缓冲毒药,劫持也7面,或者敏感信息等攻击。如下两个脚本存在HTTP应答分割攻击:-/phpBB2/privmsg.php('mode'参数)-/phpBB2/login.php('redirect'参数)这些漏洞允许攻击者执行各种页面劫持,敏感信息泄露等攻击。'/phpBB2/search.php'脚本对'search_author'参数数据缺少充分过滤,提交恶意脚本代码,当其他用户解析时可导致基于COOKIE的敏感信息泄露。
|参考资料

来源:XF
名称:phpbb-search-searchauthor-xss(16758)
链接:http://xforce.iss.net/xforce/xfdb/16758
来源:BID
名称:10753
链接:http://www.securityfocus.com/bid/10753
来源:SECUNIA
名称:12114
链接:http://secunia.com/advisories/12114
来源:BUGTRAQ
名称:20040720PhpBBHTTPResponseSplitting&CrossSiteScriptingvulnerabilities
链接:http://marc.theaimsgroup.com/?l=bugtraq&m=109034476122723&w=2