Subversion SVN协议解析远程整数溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1201607 漏洞类型 边界条件错误
发布时间 2004-06-11 更新时间 2009-07-12
CVE编号 CVE-2004-0413 CNNVD-ID CNNVD-200408-032
漏洞平台 N/A CVSS评分 10.0
|漏洞来源
https://www.securityfocus.com/bid/10519
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200408-032
|漏洞详情
Subversion是一款版本控制系统。Subversion包含的SVN协议解析器实现存在问题,远程攻击者可以利用这个漏洞对程序进行拒绝服务攻击,或可能以进程权限在系统上执行任意指令。svn协议发送数据的格式为字符串加字符串长度,解析器没有进行正确检查,就使用发送者提供的字符串长度值并分配相应的内存以存储整个字符串。如果攻击者发送的长度值很大就可能导致拒绝服务,并在一定程度上会触发整数溢出,破坏内存堆结构,精心构建提交数据可能以进程权限在系统上执行任意指令。
|受影响的产品
Subversion Subversion 1.0.4 Subversion Subversion 1.0.3 Subversion Subversion 1.0.2 Subversion Subversion 1.0.1 Subversion Subversion 1.0 Subversion Subversion 0.27
|参考资料

来源:XF
名称:subversion-svn-bo(16396)
链接:http://xforce.iss.net/xforce/xfdb/16396
来源:BID
名称:10519
链接:http://www.securityfocus.com/bid/10519
来源:FEDORA
名称:FLSA:1748
链接:https://bugzilla.fedora.us/show_bug.cgi?id=1748
来源:FEDORA
名称:FEDORA-2004-165
链接:http://www.securityfocus.com/advisories/6847
来源:SUSE
名称:SuSE-SA:2004:018
链接:http://www.novell.com/linux/security/advisories/2004_18_subversion.html
来源:GENTOO
名称:GLSA-200406-07
链接:http://www.gentoo.org/security/en/glsa/glsa-200406-07.xml
来源:subversion.tigris.org
链接:http://subversion.tigris.org/security/CAN-2004-0413-advisory.txt
来源:BUGTRAQ
名称:20041012[FMADV]Subversion<=1.04HeapOverflow
链接:http://www.securityfocus.com/archive/1/365836