PostgreSQL ODBC Driver未明远程缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1201616 漏洞类型 边界条件错误
发布时间 2004-06-07 更新时间 2009-07-12
CVE编号 CVE-2004-0547 CNNVD-ID CNNVD-200408-102
漏洞平台 N/A CVSS评分 5.0
|漏洞来源
https://www.securityfocus.com/bid/10470
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200408-102
|漏洞详情
PostgreSQL是PostgreSQL开发组所研发的一套自由的对象关系型数据库管理系统。该系统支持大部分SQL标准并且提供了许多其他特性,例如外键、触发器、视图等。PostgreSQL的ODBC驱动存在一个缓冲区溢出问题,远程攻击者可以利用这个漏洞对相关的应用程序进行拒绝服务攻击。利用这个问题,可以导致如使用php4-odbc的PHP脚本使的ApacheWEB服务程序崩溃,不过目前没有详细漏洞细节提供。
|受影响的产品
PostgreSQL PostgreSQL 7.2.1 + Debian Linux 3.0 sparc + Debian Linux 3.0 s/390 + Debian Linux 3.0 ppc
|参考资料

来源:DEBIAN
名称:DSA-516
链接:http://www.debian.org/security/2004/dsa-516
来源:XF
名称:postgresql-odbc-bo(16329)
链接:http://xforce.iss.net/xforce/xfdb/16329
来源:MANDRAKE
名称:MDKSA-2004:072
链接:http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:072