NetChat Web Server远程缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1201670 漏洞类型 边界条件错误
发布时间 2004-05-15 更新时间 2005-10-20
CVE编号 CVE-2004-2016 CNNVD-ID CNNVD-200412-220
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200412-220
|漏洞详情
NetChatWebServer是一款可基于WEB聊天的服务程序。NetChatWeb服务程序对用户提供的输入缺少充分边界缓冲区检查,远程攻击者可以利用这个漏洞对WEB服务程序进行缓冲区溢出攻击。当传递用户提供的外部输入到进程内存时,没有对数据大小长度进行正确的检查,提交超多数据可覆盖进程内存,可能导致以进程权限在系统上执行任意指令。
|参考资料

来源:BID
名称:10353
链接:http://www.securityfocus.com/bid/10353
来源:SECUNIA
名称:11637
链接:http://secunia.com/advisories/11637
来源:XF
名称:netchat-sprintf-bo(16165)
链接:http://xforce.iss.net/xforce/xfdb/16165
来源:BUGTRAQ
名称:20040517NetChatHTTPServerStackOverflow
链接:http://marc.theaimsgroup.com/?l=bugtraq&m=108481422130354&w=2
来源:NSFOCUS
名称:6452
链接:http://www.nsfocus.net/vulndb/6452