Exim头语法检查远程堆栈缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1201677 漏洞类型 边界条件错误
发布时间 2004-05-06 更新时间 2009-07-12
CVE编号 CVE-2004-0400 CNNVD-ID CNNVD-200407-022
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
https://www.securityfocus.com/bid/10291
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200407-022
|漏洞详情
Exim是一款流行的EMAIL服务器(MTA)。Exim在exim.conf配置文件中设置headers_check_syntax选项时检查头时没有正确检查缓冲区边界,远程攻击者可以利用这个漏洞发送恶意邮件,诱使Exim处理,触发缓冲区溢出。在exim3.35的accept.c和exim4.32的verify.c中:---charhname[64];char*t=h->text;char*tt=hname;char*verb="is";intlen;while(*t!=':')*tt++=*t++;*tt=0;---如果exim3.35的exim.conf文件中包含"headers_check_syntax"和exim4.32中包含"requireverify=header_syntax"选项,由于没有对"t"限制长度,可造成缓冲区溢出,目前还不知道是否可用于执行任意指令。
|受影响的产品
University of Cambridge Exim-tls 3.35 + Debian Linux 3.0 sparc + Debian Linux 3.0 s/390 + Debian Linux 3.0 ppc
|参考资料

来源:XF
名称:exim-headerschecksyntax-bo(16077)
链接:http://xforce.iss.net/xforce/xfdb/16077
来源:www.guninski.com
链接:http://www.guninski.com/exim1.html
来源:DEBIAN
名称:DSA-502
链接:http://www.debian.org/security/2004/dsa-502
来源:DEBIAN
名称:DSA-501
链接:http://www.debian.org/security/2004/dsa-501
来源:FULLDISC
名称:20040506Bufferoverflowsinexim,yetstilleximmuchbetterthanwindows
链接:http://lists.grok.org.uk/pipermail/full-disclosure/2004-May/021015.html