OMail Webmail另一远程命令执行漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1201702 漏洞类型 输入验证
发布时间 2004-05-04 更新时间 2005-10-20
CVE编号 CVE-2004-1993 CNNVD-ID CNNVD-200405-027
漏洞平台 N/A CVSS评分 10.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200405-027
|漏洞详情
Omail是一款由perl编写的结合qmail的WEB邮件系统。Omail由于未能正确过滤用户提供的包含SHELL元字符的URI参数,远程攻击者可以利用这个漏洞以WEB进程权限在系统上执行任意命令。omail.pl虽然对"和'字符进行了过滤,但对SHELL元字符没有任何检查,可导致攻击者提交类似$(rm-rf/)的命令以WEB进程权限执行。
|参考资料

来源:XF
名称:omailwebmail-checklogin-code-execution(12948)
链接:http://xforce.iss.net/xforce/xfdb/12948
来源:BID
名称:10274
链接:http://www.securityfocus.com/bid/10274
来源:SECUNIA
名称:9585
链接:http://secunia.com/advisories/9585
来源:BUGTRAQ
名称:20040504remoterootexecvulnerabilityinomail
链接:http://marc.theaimsgroup.com/?l=bugtraq&m=108377215015515&w=2