Python getaddrinfo函数远程缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1201896 漏洞类型 边界条件错误
发布时间 2004-03-10 更新时间 2009-07-12
CVE编号 CVE-2004-0150 CNNVD-ID CNNVD-200404-051
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
https://www.securityfocus.com/bid/9836
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200404-051
|漏洞详情
Python是一种开放源代码的强大功能的脚本编程语言。Python包含的'getaddrinfo'缺少充分边界缓冲区检查,远程攻击者可以利用这个漏洞以执行用户进程权限在系统上执行任意指令。Python包含的'getaddrinfo'函数允许远程攻击者通过DNS提供IPv6地址,由于对提供的地址长度缺少充分边界检查,因此超长IPv6地址可发生缓冲区溢出,精心构建提交数据可能以执行用户进程权限在系统上执行任意指令。目前没有详细漏洞细节提供。
|受影响的产品
Python Software Foundation Python 2.2.1 + Debian Linux 3.0 sparc + Debian Linux 3.0 s/390 + Debian Linux 3.0 ppc
|参考资料

来源:BID
名称:9836
链接:http://www.securityfocus.com/bid/9836
来源:DEBIAN
名称:DSA-458
链接:http://www.debian.org/security/2004/dsa-458
来源:XF
名称:python-getaddrinfo-bo(15409)
链接:http://xforce.iss.net/xforce/xfdb/15409
来源:OSVDB
名称:4172
链接:http://www.osvdb.org/4172
来源:MANDRAKE
名称:MDKSA-2004:019
链接:http://www.mandrakesoft.com/security/advisories?name=MDKSA-2004:019
来源:GENTOO
名称:GLSA-200409-03
链接:http://www.gentoo.org/security/en/glsa/glsa-200409-03.xml