OpenBSD select系统调用本地缓冲区溢出漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1204002 漏洞类型 边界条件错误
发布时间 2002-08-12 更新时间 2007-11-03
CVE编号 CVE-2002-1420 CNNVD-ID CNNVD-200304-083
漏洞平台 N/A CVSS评分 7.2
|漏洞来源
https://www.securityfocus.com/bid/5442
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200304-083
|漏洞详情
OpenBSD是加拿大OpenBSD项目组开发的一套跨平台的、基于BSD的类UNIX操作系统。OpenBSD的select调用对缓冲边界缺少正确检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击。select调用中不充分的缓冲区边界检查允许攻击者覆盖内核内存,并以内核权限执行任意代码。传统情况下,select系统调用的大小参数定义为一个有符号整数,这样内核会以有符号整数的范围来检查边界缓冲区长度,因此当攻击者使用负数时就会绕过边界检查。然而当内核为select系统调用从用户空间拷贝数据时,其大小却是作为一个无符号整数看待的,这可导致内核内存被任意数据覆盖。本地攻击者可能在内核空间中执行任意代码,从而完全控制系统。
|受影响的产品
OpenBSD OpenBSD 2.9 OpenBSD OpenBSD 3.1 OpenBSD OpenBSD 3.0
|参考资料

来源:US-CERTVulnerabilityNote:VU#259787
名称:VU#259787
链接:http://www.kb.cert.org/vuls/id/259787
来源:BID
名称:5442
链接:http://www.securityfocus.com/bid/5442
来源:XF
名称:openbsd-select-bo(9809)
链接:http://www.iss.net/security_center/static/9809.php
来源:BUGTRAQ
名称:20020812OpenBSDSecurityAdvisory:SelectBoundaryCondition(fwd)
链接:http://marc.theaimsgroup.com/?l=bugtraq&m=102918817012863&w=2
来源:OSVDB
名称:7554
链接:http://www.osvdb.org/7554