Imlib存在堆破坏漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1204570 漏洞类型 边界条件错误
发布时间 2002-03-21 更新时间 2005-05-02
CVE编号 CVE-2002-0168 CNNVD-ID CNNVD-200204-039
漏洞平台 N/A CVSS评分 7.5
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200204-039
|漏洞详情
Imlib是允许X11程序使用各种图象文件格式的库文件。Imlib由于对参数的传递边界检查不够充分问题,可导致堆破坏漏洞。Imlib在传递给malloc()的参数时没有进行充分边界检查,可导致攻击者构建特殊的图象文件,当浏览用户使用Imlib库时查看文件时,导致程序崩溃或者以浏览用户身份执行任意代码。<*链接:https://www.redhat.com/support/errata/RHSA-2002-048.html*>
|参考资料

来源:REDHAT
名称:RHSA-2002:048
链接:http://www.redhat.com/support/errata/RHSA-2002-048.html
来源:BID
名称:4336
链接:http://www.securityfocus.com/bid/4336
来源:SUSE
名称:SuSE-SA:2002:015
链接:http://www.novell.com/linux/security/advisories/2002_015_imlib_txt.html
来源:MANDRAKE
名称:MDKSA-2002:029
链接:http://www.linux-mandrake.com/en/security/2002/MDKSA-2002-029.php
来源:CONECTIVA
名称:CLA-2002:470
链接:http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000470
来源:CALDERA
名称:CSSA-2002-019.0
链接:ftp://ftp.caldera.com/pub/security/OpenLinux/CSSA-2002-019.0.txt