gnuserv X Windows MIT-MAGIC-COOKIE cookie执行任意命令漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1205793 漏洞类型 缓冲区溢出
发布时间 2001-05-03 更新时间 2005-05-02
CVE编号 CVE-2001-0191 CNNVD-ID CNNVD-200105-068
漏洞平台 N/A CVSS评分 10.0
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-200105-068
|漏洞详情
gnuserv3.12之前版本,正如装有Xemacs,不能准确检查XWindowsMIT-MAGIC-COOKIEcookie的指定长度,远程攻击者借助缓冲区溢出,或者通过使用超短cookie长度强力认证执行任意命令。
|参考资料

来源:REDHAT
名称:RHSA-2001:011
链接:http://www.redhat.com/support/errata/RHSA-2001-011.html
来源:REDHAT
名称:RHSA-2001:010
链接:http://www.redhat.com/support/errata/RHSA-2001-010.html
来源:MANDRAKE
名称:MDKSA-2001:019
链接:http://www.linux-mandrake.com/en/security/2001/MDKSA-2001-019.php3
来源:BUGTRAQ
名称:20010202Remotevulnerabilityingnuserv/XEmacs
链接:http://archives.neohapsis.com/archives/bugtraq/2001-02/0030.html
来源:XF
名称:gnuserv-tcp-cookie-overflow(6056)
链接:http://xforce.iss.net/xforce/xfdb/6056