mruby 堆缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1208528 漏洞类型 缓冲区错误
发布时间 2018-06-13 更新时间 2019-10-23
CVE编号 CVE-2018-12248 CNNVD-ID CNNVD-201806-739
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201806-739
|漏洞详情
mruby是一个Ruby语言的轻量级实现。 mruby 1.4.1版本中存在堆缓冲区溢出漏洞,该漏洞源于在大量参数传递到fiber时,mrbgems/mruby-fiber/src/fiber.c文件没有扩展栈的空间。攻击者可利用该漏洞造成越界读取。
|参考资料

来源:github.com

链接:https://github.com/mruby/mruby/commit/778500563a9f7ceba996937dc886bd8cde29b42b


来源:github.com

链接:https://github.com/mruby/mruby/issues/4038