backbone 跨站脚本漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1212462 漏洞类型 跨站脚本
发布时间 2018-05-31 更新时间 2018-06-11
CVE编号 CVE-2016-10537 CNNVD-ID CNNVD-201805-1198
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201805-1198
|漏洞详情
backbone是一个能够通过模型、视图、集合和事件为基于JavaScript的应用程序提供Backbone的软件包。 backbone 0.3.3及之前版本中的‘Model#Escape’函数存在跨站脚本漏洞,该漏洞源于用于编码元字符的正则表达式没有将XML实体(例如:<)考虑在内。远程攻击者可利用该漏洞注入任意的Web脚本或HTML。
|参考资料

来源:github.com

链接:https://github.com/jashkenas/backbone/compare/0.3.3...0.5.0#diff-0d56d0d310de7ff18b3cef9c2f8f75dcL1008


来源:nodesecurity.io

链接:https://nodesecurity.io/advisories/108