go-ipfs-deps模块安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1212483 漏洞类型
发布时间 2018-05-31 更新时间 2018-06-11
CVE编号 CVE-2016-10563 CNNVD-ID CNNVD-201805-1177
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201805-1177
|漏洞详情
go-ipfs-deps module是一个用于从npm安装go-ipfs二进制文件的模块。 go-ipfs-deps模块0.4.4之前版本中存在安全漏洞,该漏洞源于程序通过HTTP协议下载资源。攻击者可利用该漏洞实施中间人攻击,控制资源的完整性。
|参考资料

来源:github.com

链接:https://github.com/diasdavid/go-ipfs-dep/pull/12


来源:nodesecurity.io

链接:https://nodesecurity.io/advisories/156