PoDoFo 缓冲区错误漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1212890 漏洞类型 缓冲区错误
发布时间 2018-07-02 更新时间 2020-07-15
CVE编号 CVE-2018-12983 CNNVD-ID CNNVD-201807-045
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201807-045
|漏洞详情
PoDoFo是一个开源的、使用C++编写的PDF文件格式的库。 PoDoFo 0.9.6-rc1版本中的PdfEncrypt.cpp文件的‘PdfEncryptMD5Base::ComputeEncryptionKey()’函数存在基于栈的缓冲区越界读取漏洞。远程攻击者可借助特制的pdf文件利用该漏洞造成拒绝服务。
|参考资料

来源:bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=1595693