libsixel 安全漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1219828 漏洞类型 资源管理错误
发布时间 2018-07-15 更新时间 2019-10-23
CVE编号 CVE-2018-14072 CNNVD-ID CNNVD-201807-1147
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201807-1147
|漏洞详情
libsixel是一个为DEC SIXEL图形和其他转换器程序提供编码/解码实现的软件包。 libsixel 1.8.1版本中的decoder.c文件的‘sixel_decoder_decode’函数、fromsixel.c文件的‘image_buffer_resize’函数和fromsixel.c文件的‘sixel_decode_raw’函数存在内存泄露漏洞。远程攻击者可通过诱使用户打开特制的文件利用该漏洞造成拒绝服务。
|参考资料

来源:github.com

链接:https://github.com/saitoha/libsixel/issues/67#issue-341198610