Ansible mysql_user模块输入验证漏洞

QQ空间 新浪微博 微信 QQ facebook twitter
漏洞ID 1229910 漏洞类型 输入验证错误
发布时间 2018-07-27 更新时间 2019-10-17
CVE编号 CVE-2016-8647 CNNVD-ID CNNVD-201807-1906
漏洞平台 N/A CVSS评分 N/A
|漏洞来源
http://www.cnnvd.org.cn/web/xxk/ldxqById.tag?CNNVD=CNNVD-201807-1906
|漏洞详情
Ansible是美国Ansible公司的一款计算机系统配置管理器,它可用于发布、管理和编排计算机系统。Mysql_user module是其中的一个MySQL用户管理模块。 Ansible中的mysql_user模块2.2.1.0之前版本存在输入验证漏洞,该漏洞源于程序没有正确地更改密码,导致更改前的密码仍然有效。攻击者可利用该漏洞绕过安全限制,执行未授权的操作。
|参考资料

来源:bugzilla.redhat.com

链接:https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-8647


来源:github.com

链接:https://github.com/ansible/ansible-modules-core/pull/5388